scripting error i don't understand

RacerX
Commander
Commander
 
Posts: 535
Joined: 26th Mar 2004
Location: Missouri. USA

scripting error i don't understand

Postby RacerX » Mon Aug 21, 2006 4:07 am

the current script i'm working on give me an error that says

line (29) :Error Expecting Symbol.

what symbol???
Image

RedHotChiliDog
Field Marshal
Field Marshal
 
Posts: 2742
Joined: 14th Nov 2000
Location: Gahanna, Ohio

Postby RedHotChiliDog » Mon Aug 21, 2006 4:37 am

Hmm, that is interesting.

Do you have copies of the n101DLG.ssl, n101Info.ssl, and n101Init.ssi files in the same directory as the n101.ssl file that I emailed back to you?

I just tried again to make sure, and I was able to recompile the script with no problems. I will send you the other files that I used on my machine, though everything but the n101.ssl was from the stock n101 multiplayer script.
RedHotChiliDog

Klingons and Potato Chips are better with ridges.

brianmoler.com - Mission scripting and other strangeness

RacerX
Commander
Commander
 
Posts: 535
Joined: 26th Mar 2004
Location: Missouri. USA

Postby RacerX » Mon Aug 21, 2006 4:39 am

yea all i did was copy and past your ssl to the folder
still don't understand why i get the error

** just got the new files and placed them in the folder overwritting the others and still get the same error
Image

RedHotChiliDog
Field Marshal
Field Marshal
 
Posts: 2742
Joined: 14th Nov 2000
Location: Gahanna, Ohio

Postby RedHotChiliDog » Mon Aug 21, 2006 4:46 am

I just sent copies of all of the files that I have for the n101 script with your modifications via email. I wonder if you get the same error when compiling with this set of files instead?

If you are able to compile with the set of source files that I just sent, then you may want to send a copy of your n101 script source so that I can do a file comparison between what we have to see what the differences are.

In any event, I have also sent the compiled scripts along with the source, so you can test the script while I try to find out why you are not able to compile it.
RedHotChiliDog

Klingons and Potato Chips are better with ridges.

brianmoler.com - Mission scripting and other strangeness

RacerX
Commander
Commander
 
Posts: 535
Joined: 26th Mar 2004
Location: Missouri. USA

Postby RacerX » Mon Aug 21, 2006 4:58 am

yea i got the files and still get the same error when i try to compile also I tried the script which you compiled and still get the same affect the object shows up as friendly and doesn't cloak on approach.
Image

RedHotChiliDog
Field Marshal
Field Marshal
 
Posts: 2742
Joined: 14th Nov 2000
Location: Gahanna, Ohio

Postby RedHotChiliDog » Mon Aug 21, 2006 4:59 am

Racer,

It looks like a screwed up, oops :D

Apparently, I did not completely define a variable in the version of the n101.ssl file that I sent to you. It would appear that since I use the Microsoft C compiler to pre-compile my scripts, that it is able to overlook this sort of problem. This means that you are probably using a different C compiler than I am and would explain why you are getting the error when I am not.

I have fixed the problem and will be sending you another copy via email shortly...
RedHotChiliDog

Klingons and Potato Chips are better with ridges.

brianmoler.com - Mission scripting and other strangeness

RedHotChiliDog
Field Marshal
Field Marshal
 
Posts: 2742
Joined: 14th Nov 2000
Location: Gahanna, Ohio

Postby RedHotChiliDog » Mon Aug 21, 2006 5:01 am

RacerX wrote:yea i got the files and still get the same error when i try to compile also I tried the script which you compiled and still get the same affect the object shows up as friendly and doesn't cloak on approach.


Hmm, I will take a look and see why the compiled version is behaving this way. Do you know if the wormhole has a cloak resource or not?
RedHotChiliDog

Klingons and Potato Chips are better with ridges.

brianmoler.com - Mission scripting and other strangeness

RacerX
Commander
Commander
 
Posts: 535
Joined: 26th Mar 2004
Location: Missouri. USA

Postby RacerX » Mon Aug 21, 2006 5:03 am

yea i'm using an antique borland 5.5 compiler
Image

RedHotChiliDog
Field Marshal
Field Marshal
 
Posts: 2742
Joined: 14th Nov 2000
Location: Gahanna, Ohio

Postby RedHotChiliDog » Mon Aug 21, 2006 7:39 am

Finally, I have success!

I have fixed the error that was causing your problem with the Borland compiler. I have also fixed the problem with the ship not cloaking.

When playing the script, I had to crank the power to the sensors WAY up to detect a cloaked ship from that far away from my ship. Even then, it was a hit or miss type situation, but I was able to fix on it long enough to warp to the target.

You should be able to target the wormhole as an enemy ship too.

I have placed some debug dialog as chat messages to indicate the cloaked status of the wormhole. You can remove that if you like, as it was just there for troubleshooting purposes.

I have sent the script to you via email. Let me know how it works out.
RedHotChiliDog

Klingons and Potato Chips are better with ridges.

brianmoler.com - Mission scripting and other strangeness

RacerX
Commander
Commander
 
Posts: 535
Joined: 26th Mar 2004
Location: Missouri. USA

Postby RacerX » Mon Aug 21, 2006 8:27 am

man i really do thank you for all the help. and anyone that stays up till this lat at night is a fine work in my book.

But it didn't compile... so i cut the changes you made and placed them in a fresh ssl and it compiled but with the exact same problem that we started out with.

i'm starting to wonder if it's ever going to work.
Image

RacerX
Commander
Commander
 
Posts: 535
Joined: 26th Mar 2004
Location: Missouri. USA

Postby RacerX » Mon Aug 21, 2006 8:34 am

ok it's working why i have no idea . i had to use the files that you sent earlier to get it to compile correctly but it is working hip hip horay :)

i can't tell you how much it means that you got it to do what it need to do..

I'll send my girlfriend to give you a kiss for it ;)
Image

RedHotChiliDog
Field Marshal
Field Marshal
 
Posts: 2742
Joined: 14th Nov 2000
Location: Gahanna, Ohio

Postby RedHotChiliDog » Tue Aug 22, 2006 6:56 am

Was no problem at all. Just let me know if you need to know why I coded things the way I did in the script.
RedHotChiliDog

Klingons and Potato Chips are better with ridges.

brianmoler.com - Mission scripting and other strangeness

RacerX
Commander
Commander
 
Posts: 535
Joined: 26th Mar 2004
Location: Missouri. USA

Postby RacerX » Tue Aug 22, 2006 10:29 pm

wll i do have questions.. because i need to add another object to the system (ds9) . I had orignally planned on using the same trigger for the the station except instead of the affect being a cloak, it would be a ship repair or a ship change option.

but i'll save those for when i get that far. today i was able to get the fighters to exit the wormhole and attack so maybe in a day or so i'll have the question better prepared.
Image


Return to Mission Scripting